da.phhsnews.com


da.phhsnews.com / Sådan kontrolleres, om dine udvidelser vil stoppe med at fungere med Firefox 57

Sådan kontrolleres, om dine udvidelser vil stoppe med at fungere med Firefox 57


Med Firefox 57, der er planlagt til udgivelse den 14. november 2017, vil Mozilla afslutte support for tidligere udvidelser og understøtte kun nyere WebExtensions . Sådan kontrolleres, om dine udvidelser ikke længere fungerer, og hvordan du kan bruge dem efter november, hvis du har brug for det.

Hvorfor XUL-udvidelser er væk

Alle traditionelle udvidelser, herunder XUL-udvidelser, afbrydes. De var meget stærke, men det var både en styrke og en svaghed. Den store styrke i disse udvidelser betød, at de kunne ændre Firefox-browserkoden, hvilket kunne medføre ustabilitet og uskyldige malware-tilføjelser.

Mozilla har i stedet arbejdet på WebExtensions, som ligner på Chrome og Edges tilføjelser . Dette er fremtiden for Firefox-udvidelser. Fordi disse tilføjelsesprogrammer skal arbejde på en mere standard måde og ikke kan ødelægge Firefox's interne kode, bør de medføre færre problemer. Det bør også være nemmere for udviklere at tilføje tillæg fra Chrome til Firefox.

Firefox understøtter i øjeblikket både traditionelle (arv) udvidelser og WebExtensions. Med Firefox 57 vil de ældre udvidelser stoppe med at virke, og kun nyere WebExtensions vil fungere. Denne ændring findes allerede i Firefox Nightly, den førende udvikling af Firefox. Udviklere er blevet skubbet for at opgradere deres udvidelser, men ikke alle har, hvilket fører os til problemet.

Sådan ser du om dine udvidelser vil stoppe med at arbejde

Hvis du bruger Firefox i dag, kan du tjekke for at se, hvilken af ​​dine udvidelser vil ophøre med at fungere i version 57. For at kontrollere, skal du klikke på menuen> Tilføjelser og vælge kategorien "Udvidelser".

Ældre udvidelser, der stopper med at arbejde, er mærket med et "Legacy" -tag, hvis du bruger Firefox 55 eller nyere. Moderne WebExtensions, der fortsætter med at virke, vises normalt.

Sådan søger du efter nye udvidelser

Hvis en udvidelse har "Legacy" -tag, kan du tjekke denne liste over populære udvidelser med oplysninger om deres opgraderingsstatus. For eksempel er LastPass i ovenstående skærmbillede markeret som Legacy-udvidelse, der vil stoppe med at arbejde, men vi kan se, at udviklerne planlægger at erstatte det med en WebExtension før Firefox 57's udgivelsesdato.

For mindre populære udvidelser er det muligvis nødvendigt at udføre en websøgning for at se om udvikleren planlægger en opdatering. Udviklere skal sende deres udvidelser til WebExtensions, og ikke alle udviklere vil gøre det.

Hvis en udvidelse du er afhængig af, vil stoppe med at arbejde, kan du muligvis søge efter et moderne alternativ, der gør noget lignende. Du kan søge efter kun tilføjelser, der er kompatible med Firefox 57 eller nyere på Mozilla Add-ons-webstedet.

En tilføjelse, der har tagget "Kompatibel med Firefox 57+", er en WebExtension, der fortsætter med at fungere. For eksempel er det ikke muligt at installere den udvidelse af User Agent Switcher, vi har installeret, så vi sandsynligvis vil installere en af ​​de mere moderne brugeragent-switcher-udvidelser.

RELATED: Browserudvidelser er et privatlivsmarmer: Stop med at bruge så mange af dem

Dette er en god tid til at vurdere, om du faktisk har brug for alle disse udvidelser. Browserudvidelser kan være farlige, så det er en god idé at kun få dem installeret, hvis de er rigtig nyttige for dig og fra en troværdig kilde.

Hvordan man bruger gamle udvidelser

Hvis du virkelig har brug for en gammel udvidelse, der er en måde at holde dem sikkert på. Skift til Firefox Extended Support Release, også kendt som Firefox ESR. Dette er en langsommere version af Firefox, der hovedsagelig er beregnet til virksomheder, der ikke ønsker større funktion opgraderinger hver sjette uge.

Den nuværende Firefox ESR-udgivelse er baseret på Firefox 52 og vil blive understøttet af sikkerhedsopdateringer indtil 26. juni 2018 . Da den er baseret på Firefox 52, vil ældre udvidelser fortsætte med at fungere uden problemer.

Efter 26. juni 2018 skal du opgradere til nyere versioner af Firefox ESR, der ikke længere understøtter tidligere udvidelser, hvis du vil fortsæt med at modtage sikkerhedsopdateringer. Dette er ikke en permanent løsning, men det er en god måde at fortsætte med at bruge dine nuværende udvidelser i yderligere syv måneder, mens du vurderer mere moderne alternativer.


Sådan overvåger du den kommende solformørkelse

Sådan overvåger du den kommende solformørkelse

Omkring en måned fra nu bliver Nordamerikanerne behandlet til en spektakulær solformørkelse. Men du kan ikke bare løbe udenfor på din frokostpause og kigge uden de rette forholdsregler. Lad os hjælpe dig med at forberede dig nu for at nyde solformørkningen på en sikker måde. Hvilken solformørkelse? Hvis du ikke har hørt den 21.

(how-top)

Sådan slår du din smartphones VR-oplevelse til dit fjernsyn

Sådan slår du din smartphones VR-oplevelse til dit fjernsyn

Virtual Reality er takket være smartphones langt over det sidste år eller to. Men VR er virkelig kun cool for den person, der faktisk bruger den på det tidspunkt. Vil dine venner se hvad du ser? er Du kan dele din skærm med dem omkring dig, så længe du har en Chromecast (til Android-enheder) eller Apple TV (til iOS-enheder).

(how-top)