da.phhsnews.com


da.phhsnews.com / Sådan ser du Hulu på Ubuntu og andre Linux-distributioner

Sådan ser du Hulu på Ubuntu og andre Linux-distributioner


Hulu virker ikke ude af købet på moderne Linux-distributioner. Mens Netflix "virker bare", hvis du bruger Google Chrome, er Hulu's DRM blevet gammel og klumpet. Du kan få Hulu til at arbejde på Linux, men det vil tage lidt tilpasning.

Det var ikke altid så svært. Tilbage, da Netflix gjorde livet svært for Linux-brugere, tilbød Hulu endda en Linux desktop app. Men den desktop app er nu afbrudt. Hulu er afhængig af Adobe Flash, og Adobe Flashs DRM-kode falder fra hinanden på Linux.

Du skal bruge Firefox

RELATED: Brug Firefox på Linux? Din Flash Player er gammel og forældet! ​​

Her er problemet: Hulu er afhængig af den gamle Adobe Flash DRM-kode, der kræver et Linux-bibliotek kendt som HAL. Denne gamle HAL-software er dog ret forældet og er ikke installeret som standard på moderne Linux-distributioner i årevis. Du skal installere kompatibilitetspakker, der gør det muligt for denne HAL-baserede DRM at fungere.

Du skal også bruge Mozilla Firefox til at se Hulu. Den gamle HAL-baserede DRM fungerer kun i den ældre version af Linux Flash plug-in Firefox-tilbud. Den nyere PPAPI (Pepper API) -baserede Flash Player inkluderet i Google Chrome fungerer ikke med Hulu's gamle DRM-kode.

Ja, det betyder at du skal se Netflix i Google Chrome og Hulu i Mozilla Firefox. Er ikke livet grand?

Trin 1: Installer Flash til Firefox

Først skal du installere Flash Player plug-in til Firefox. Hvis du ikke har installeret Flash endnu, vil du se en besked, der siger, at Hulu har brug for Flash installeret, når du prøver at se det.

Du kan generelt installere Flash fra din Linux-distributionens softwarelager. For eksempel, på Ubuntu, skal du åbne Ubuntu Software Center og søge efter "flash". Installer "Adobe Flash plug-in" softwaren.

Sørg for at installere Flash plugin designet "til Mozilla," "for Firefox" eller "NPAPI" -versionen af ​​plug-in'en. "PPAPI" eller "for Chrom" -versionen af ​​Flash fungerer kun med Chrome og Chrome-baserede browsere.

Trin to: Installer det gamle HAL-bibliotek

Når du har Firefox og Flash-plug-in til Firefox installeret , kan du gå til Hulu hjemmeside og prøve at spille en video. Du ser dog sandsynligvis en fejlmeddelelse, når du gør det. Fejlmeddelelsen siger "Der opstod et problem med at afspille dette beskyttede indhold. (Fejlkode: 2203) ". Hulu vil bede dig om at sikre, at HAL-pakken er installeret, ryd din flashcache og nulstil licensfiler.

Hulu forbinder dig med en Adobe-side, der anbefaler at du installerer pakken med navnet "hal", men denne pakke er ikke længere lige til stede til installation på moderne versioner af Ubuntu og andre moderne Linux-distributioner.

I stedet for at installere en version af hele HAL-pakken - fra "zombie HAL PPA", som det er kendt i Ubuntu-kredse, vil vi henvise dig til en mere let løsning.

Martin Wimpress, projektledende for Ubuntu MATE, giver en "hal-flash" PPA, der giver alt, hvad du behøver for at afspille DRM-beskyttet Flash-indhold uden at installere hele HAL-laget. Denne software skal du tilføje denne PPA til dit Ubuntu-system (dette skal også fungere på Linux Mint og andre Ubuntu-afledte distributioner). Åbn en terminal fra bindestreg og indsæt eller skriv følgende kommandoer i rækkefølge, tryk på Enter efter hver. Den første kommando tilføjer PPA, den anden downloadsoplysninger om pakkerne i den, og den tredje installerer HAL-biblioteket.

sudo add-apt-depot ppa: flexiondotorg / hal-flash

sudo apt-get opdatering
sudo apt-get install libhal1-flash
Hvis du bruger en anden Linux-distribution - det vil sige noget andet end Ubuntu, Linux Mint eller noget afledt af Ubuntu - skal du jage en HAL-pakke til Flash leveret til din Linux distribution. Det kan være en del af din Linux-distributionens pakkelager eller det kan være i et tredjepartsbibliotek, som det er til Ubuntu.

Når det er installeret, skal du besøge Hulu i Firefox, prøv at afspille en video igen, og det skal nu fungere i stedet for at vise dig et "beskyttet indhold" fejlmeddelelse.

Hvis du fortsætter med at se en fejlmeddelelse, skal du muligvis lukke Firefox og genstarte den. Hvis det ikke virker, skal du prøve at genstarte computeren helt, inden du fortsætter.

Dette har været et problem i mange år nu. Adobe-siden siger, at HAL skal installeres på versioner 10.x og op af Ubuntu - det refererer til versioner af Ubuntu, der blev frigivet helt tilbage i 2010.


Adobe ønsker ikke længere at udvikle Flash på Linux. Den rigtige løsning her kommer ikke, når Adobe løser sin Flash DRM. I stedet skal Hulu skifte til moderne HTML5-baseret videoafspilning, som Netflix bruger i Google Chrome. Indtil de gør det, vil Linux-afspilning være lidt af et besvær.


Hurtigt adgang til kladder i iOS Mail App med en langvarig presse

Hurtigt adgang til kladder i iOS Mail App med en langvarig presse

Måske har du udkast til gamle beskeder, du ikke har tid til at afslutte, eller måske bruger du udkastsmeddelelser som skabeloner du behøver ikke at skrive ting igen og igen. Men du bruger udkast, her er en hurtigere måde at få adgang til dem i iOS Mail-appen i stedet for at søge rundt i din Udkast-mappe.

(how-to)

Sådan reduceres mængden af ​​data, som dit Apple TV forbruger

Sådan reduceres mængden af ​​data, som dit Apple TV forbruger

Apple TV er en standset lille set-top streaming-enhed med mange forskellige, men det er ikke ligefrem sparsommeligt, når det kommer til din internetforbindelse. RELATERET: Er det endelig en god tid at købe et Apple TV? Hvis du har en langsommere forbindelse, eller hvis du har en datalåg, er der nogle måder, du kan reducere, hvor meget data, som din Apple TV bruger regelmæssigt.

(how-to)